Kapat
Siberdinc > Firewall > Vlanlar Arası Haberleşme 2 – (Fortigate Routing)

Merhaba. Daha önce L3 Switch üzerinden routing yaparak VLAN’lar arası haberleşme işlemini anlatmıştım. Bu yazıma buradan ulaşabilirsiniz.

Bugünkü yazımda ise genel olarak kullanılan yapı olan, Fortigate Firewall üzerinden VLAN’lar arası haberleşme işlemini anlatacağım. GNS3 üzerinde yapacağımız işleme başlayalım. GNS3 üzerinden imagelerin eklenmesi ve yapılandırılması anlatılmayacaktır. Bununla ilgili yazıma buradan ulaşabilirsiniz.

Senaryomuz şu şekilde olacak. Satış birimindeki Erdinc kullanıcısından Muhasebe birimindeki Gökay kullanıcısına erişmeye çalışacağız.

1 – GNS3 üzerinde topolojimizi ve kablo bağlantılarımızı yaptıkran sonra, Kullanıcılara manuel olarak IP verme işlemini yapıyoruz. Ben GNS3 üzerinde VNC makine çalıştırdığımdan dolayı cihazlara IP’yi komut üzerinden verdim. Tabii ki VLAN’a ait Gateway IP’sini vermeyi unutmayın!

2- Yapımızda VLAN’lardan Backbone Switch tarafına ACCESS , Backbone Switch’den Fortigate tarafına doğru ise TRUNK işlemi yapmamız gerekiyor.

TRUNK işlemi için Backbone Switch üzerinde aşağıdaki komutları çalıştırıyorum. Biz GNS3 üzerinde Cisco Switch image ekledik ve işlemlerimizi onun üzerinden yapılandırıyoruz. Switchlere göre komutlara farklılık gösterebilir.

config  terminal

interface gigabitEthernet 0/2

switchport trunk encapsulation dot1q 

switchport mode trunk

no shutdown

end

3-  L2 Switch’lerin Backbone (L3) switch ile bağlantı kurduğu portlar VLAN port ataması yapılması gerekiyor. Biz işlemleri 0/1 ve 0/0 için ACCESS yapacağız.

conf terminal

interface gigabitEthernet 0/1

switchport mode access

switchport access vlan 10 

no shutdown

end

(Aynı işlemi 0/0 portuna göre VLAN 11 içinde yapacağız)

conf terminal

interface gigabitEthernet 0/0

switchport mode access

switchport access vlan 11 

no shutdown

end

ACCESS ve TRUNK işlemlerimi tamamladık.

4- Access ve Trunk işlemlerimizi tamamladıktan sonra. L3 Switch ile Fortigate arasında yapılacak olan işlemlere geçiyoruz.

Aşağıdaki yapıda Switch’in (Gi1/0) ile port2 arasında  Access mode olacak ve VLAN 14’e ataması yapılacak. Ayrıca Fortigate’imizin arayüzüne erişim için kullanacağımız 192.168.14.10 Ubuntu makinemizin bağlı olduğu Gi0/3 interface’ini de Access mode olarak yapılandırıp VLAN 14’e atayacağız.

Bu işlemi neden yaptık diye sorarsanız eğer, Herhangi bir yanlış işlem sonucunda bağlantı kopmaması için, Fortigate’e erişeceğimiz bilgisayarımızı ayrı bir Management interface’sinde yapılandırarak erişimimiz direkt oradan sağlamış olduk.

Tabi burada direkt Fortigate’e bir Client bağlantısı kurarak da yapabilirdik.

conf terminal

interface gigabitEthernet 0/3 (Aynı işlemi 1/0) içinde yapıyoruz!

switchport mode access

switchport access vlan 14 

no shutdown

end

5- Fortigate cihazımızın üzerinde sağ tıklayarak Console diyoruz ve Konsol ekranına geçiyoruz. Port2’ye 192.168.14.254 IP’sini atıyoruz.

6- Ubuntu makinemizden Fortigate arayüzüne ping başlatıp arayüze erişim sağlayacağız.

7- Arayüzüne erişim sağladıktan sonra Interfaces – Create New – Interface diyerek VLAN’larımızı oluşturacağımız ekrana geçiyoruz.

VLAN 10 için yapılandırma bilgisi aşağıdaki şekilde olmalıdır; (Bu işlemleri diğer VLAN’lar içinde yapıyoruz)

8- VLAN’larımızı oluşturduktan sonra, IPv4 Policy menüsüne geliyoruz ve kural yazıyoruz. (Fortigate’de kuralsız hiçbir işlem olmaz!)

SatisVLAN(10) ‘dan MuhasebeVLAN(11)’e doğru bir kural yazıyoruz.

Aynı işlemi MuhasebeVLAN(11)’den SatisVLAN(10) ‘a doğru da yazıyoruz.

Kurallarımız aşağıda olduğu şekilde görüyoruz.

9- Kuralımız ve VLAN yapımızı olup olmadığını test ediyoruz.

Fortigate üzerinden VLAN’lar arası haberleşme işlemi bu kadar 🙂

Daha önce L3 Switch üzerinden routing yaparak VLAN’lar arası haberleşme işlemini anlatmıştım. Bu yazıma buradan ulaşabilirsiniz.

Bu yazımda ise Fortigate üzerinden Routing işlemini anlatmış olduk.

Bir sonraki yazıda görüşmek üzere.

Makalelerimden ilk siz haberdar olmak istiyorsanız. Mail aboneliği kısmından abone olabilirsiniz.

Veya TELEGRAM Duyuru Kanalıma Katılabilirsiniz.

Sağlıklı ve Güvenli Günler Dilerim.

 

 

 

 

 

 

 

 

 

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Kapat

DMCA.com Protection Status